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1. Installation 
For installing IKOSA ISTIX use the provided IKOSA ISTIX setup, accept the license agreement and 
chose an installation directory. It is possible to have different versions installed side-by-side. Before 
uninstalling IKOSA ISTIX make sure all IKOSA ISTIX applications are closed. 

1.1. License and Activation 
By default IKOSA ISTIX is executed in demo mode. The window title then contains the (“Demo 
Mode”) suffix. IKOSA ISTIX is fully functional, but draws watermarks (“IKOSA ISTIX Demo”) into newly 
recorded image tiles.   

IKOSA ISTIX is unlocked with a software License File. The license is bound to a single computer. The 
computer’s unique finger print is contained in a License Request File. The actual License File will be 
created specifically for a License Request File. The activation procedure does not require Internet. 
You can create the License Request File on the computer where IKOSA ISTIX is installed and then send 
the file from any other computer.  

The activation process goes as follows: 

1. Install IKOSA ISTIX on your computer.  
2. Start IKOSA ISTIX and create a License Request file: Main Menu > Help > License > Create 

License Request File. 
You will be prompted to select where the license request file (*.licReq) shall be stored 

 

3. Send the License Request File to your distributor. They will create the License File based on 
this License Request File and send the License File (*.lic) back to you. 

4. Import the License File into IKOSA ISTIX: Main Menu > Help > License > Import License File 
You will be prompted to select the License File (*.lic).  
The import will only work on the same computer where you created the License Request File.  

5. Congratulations: IKOSA ISTIX is now unlocked.  
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2. General Usage 
This part is a step-by-step explanation of the general usage of IKOSA ISTIX. For further explanation 
and details please refer to the chapters Further Functionality and All Settings. 

2.1. Connect a Camera 
Before starting IKOSA ISTIX, please make sure a camera is connected and turned on. The settings 
allow for switching between different cameras. In case no camera is connected demo sequences can 
be viewed instead.  

If the grabbed frames per second are too low, they are drawn in red. A likely reason, is that it is 
connected to a USB 3 port. IKOSA ISTIX will then still work, but during stitching the microscope stage 
needs to be moved significantly slower compared to when the camera’s video arrives at full speed. 

2.2. Start IKOSA ISTIX  

Start the IKOSA ISTIX.exe  and wait for the home screen to load. 

2.3. Home Screen 
As shown in the image below, the left column of the home screen shows the live camera image. The 
capture workspace is located in the right column. The status bar on the bottom yields general 
information about the currently used camera, resolution, etc. 

2.3.1. Capture Workspace 
In the workspace you can select, view, as well as delete and browse previously captures slide images. 
The workspace can be searched for using the filter on the top right. In the lower right corner the user 
can switch from tiles view to list view. For changing the data format of the stitching images, please 
refer to Capture Workspace Options. 
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2.3.2. Camera Performance 
The current camera and grabbed frames per second (“Grab: <value> fps“) are always displayed in the 
status bar at the bottom of the main window: 

 

 
TIP: If only around 5 or less frames per second are grabbed, check if the USB port is really a 
USB 3.0 port (blue).  

 

2.4. Slide Stitching 
In order to perform slide stitching the following steps shall be performed in general. For more 
settings, please refer to the chapters Further Functionality and All Settings. 

 
Follow these steps before you scan your first slide: 

1) Check if the camera is mounted correctly: move only the horizontal know and check 
that the stitched images do not have a vertical offset 

2) Select Microscope Objective (e.g. based on the color code) 
3) Calibrate pixel resolution (microns / pixel) 
4) White Balancing  
5) Background Shading Correction (do not change the camera settings anymore 

afterwards) 
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2.4.1. Select Current Objective 
Before starting the stitching/recording please select the currently used objective as shown in the 
image below. In case no objective has been added yet, please refer to Add, Remove and Edit 
Objectives. 

2.4.2. Adjust Exposure Time 
Adjust the exposure time such that you see a well illuminated, but not overexposed, image in the live 
view. 

  

Is recommended that you navigate to an area outside of the specimen on the slide where only 
background is visible. Increase the exposure time slider until the first areas in the image are almost 
completely white. Don’t increase the exposure time any further or else those areas will be 
overexposed. The exposure time may also affect the sharpness of the image perceived by IKOSA 
ISTIX. In case of underexposure or overexposure a warning is displayed during stitching. 

 
In order to prevent motion blur, it is preferable to work with low exposure times < 5 msec. 
Turn up the microscope’s light source power to compensate the lower exposure time.  

 

 
We recommend to view at the monitor and not through the microscope while stitching.  
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The live view could now look like this: 

 

Clearly, there are two problems left with this image:  

- The background is lit unevenly 
- The image is not correctly white-balanced. It is slightly blueish in this example.  

The next two paragraphs will address this. 

2.4.3. Color White Balance 
Navigate to an area on the slide where only background is visible. The auto-white balance 
functionality is available for most cameras. For other cameras, the white balance needs to be 
adjusted manually.  

Cameras that support automatic white balancing: 

Click the white-balance button in the main tool bar:  . During the next five seconds it will 
automatically adjust the color settings to achieve a correctly-white balanced image. If five 
seconds have not been sufficient to achieve a satisfying result, the auto-white-balance 
button can be clicked a second time. 

Cameras not do not support automatic white balancing:  

The color temperature can be tuned manually as described in the Change Camera Color 
Settings chapter.   

Now the image could like this: 

 

2.4.4. Background Shading Correction 
IKOSA ISTIX employs a shading correction that works with a reference image. The reference image is 
computed from 1-3 background locations. These are then analyzed and during stitching the recorded 
images are rectified accordingly. The reference image is stored as a property of the objective, i.e. you 
should create a shading correction reference image for each objective.  

 

The shading correction wizard is available in the Microscope Objective Selection Popover: 
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Click the  button to open the wizard.   

 

Move to a region on the slide without any foreground and then click the “Background #1” button to 
save the image. Then move to a second background location and repeat the process. Finally, repeat it 
for a third position. When clicking “OK”, the three background images will be fused into a single 
reference image.  

Now, the shading correction controls have been updated. Click the  button, if you are interested 

what the reference image looks like. Shading correction has automatically been enabled:   

 

 

2.4.5. Pixel Resolution Calibration 
The pixel resolution in microns per pixel needs to be calibrated. This is one-time procedure that does 
not have to be repeated. The calibration can be carried out in two alternative ways:  

a) If you have a calibration slide at hand or some other object where you know the absolute 
size in millimeters, then it is easiest to draw a line in the live image and specify the length. By 
dividing the length with the number of pixels, the size of a pixel can be calculated. 

b) Alternatively, you can specify your camera sensor’s pixel size (from the camera’s data sheet) 
as well as the camera adapter’s and objective’s magnification.  

The resulting resolution will be applied to all objectives. The resolution calibration dialog is available 
from the main “File” menu. 
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In this example, a calibration slide was used. The yellow line is created by clicking once for the start 
point and once again for the end point. Here, the cross hair has a diameter of 1 mm, and so the 
yellow line has a length of 0.5 mm, which amounts to 0.347 microns per pixel.  

2.4.6. Start and Stop Stitching/Recording 

In order to start the stitching, press the Rec-button  . You will be automatically asked to 
specify a name for the slide to be recorded. The slide will be stored in the workspace. You can change 
the workspace directory in the options dialog.  

 

In order to stop the stitching/recording press the Stop-button  . The data is saved to the 
workspace and a thumbnail is created and added to the home screen. 

 

If you want to discard the recorded slide and start over, press the  button instead.  
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2.4.7. Stitching/Recording 
After having pressed the record button the stitching is performed automatically when the 
microscope stage is moved in the x- or y-direction. The stitched image is initially shown in the main 
window and is updated dynamically.  

The current position within the whole-slide is depicted with a green frame when the stitching is 
performed successfully. The frame, however, turns red in case IKOSA ISTIX has lost track or focus, i.e. 
the object was moved too fast.  

 

2.4.8. Live View 
The floating live-view window in the above screenshot’s top right corner shows the current live 
image. You may choose to resize the live view or position it outside of the main window. If you have 
two monitors, you may want to fullscreen it on the second monitor. At the  

Warnings about overexposure , underexposure  and when the object is out 
of focus  are displayed in the upper right corner. 

2.4.9. Sharpness-Meter 
The bar on the floating live view’s bottom edge indicates the image’s focus. The percentage drops 
when the camera loses focus, i.e. the captured image is not sharp enough. This may also happen 
when the object is moved too fast.  

 

2.4.10. Scan Speed-Meter 
The bar on the bottom of the current-tile-rectangle indicates whether you are moving the 
microscope too fast. The percentage drops when the object is moved too fast and stitching becomes 
inaccurate or impossible. After all, two consecutive camera images need to overlap or else they 
cannot be related to each other.  

 

 

Floating Live View 

Where new image 
has been added  
to the whole-slide 

Sharpness-Meter 

Active part of image 
that will be added  
to whole-slide 

Scan-Speed-Meter 
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2.4.11. Check Camera Rotation 
If the camera is mounted slightly rotated, moving the stage horizontally will lead to a vertical offset in 
the stitched tiles as seen in the screenshot below. Readjusting the mounted camera can be tricky. To 
help, enable the “camera movement trace” option by enabling the  button in the status bar.  

The will show a line that connects each tile’s center point with each other. If the current angle is very 
close to a perfectly accurate horizontal or vertical movement (i.e. 0, 90, 180 or 270 degrees), the line 
is painted in green, if it is acceptable in orange, and if it is off by more than three degrees in red. 
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3. Annotations and Measurements 
Starting version 1.2.0 measurements can be carried out both in the virtual microscope and in the live 
camera feed. 

3.1. Measurements in Camera Live Feed 
The live camera view supports carrying out measurements. A click into the image will mark the 
starting point of a new line and the next click will mark the end-point. A third click will start a second 
line, and so on. A click on the secondary mouse button will clear all previously created lines.  

 

3.2. Measurements in Virtual Microscope 

 

Annotation 
Toolbar 

 

  
Annotations 

Number of 
selected and 
total 
annotations 

Ruler 
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Drag Tool 
The tools are mutually exclusive and one of 
the tools has to be selected. By default the 
Drag Tool is enabled.  
Annotations are created by selecting one of 
the annotations tools and then clicking into 
the slide and creating the shape by dragging 
the mouse pointer while keeping the primary 
mouse button pressed.  
The mouse wheel is used to zoom, regardless 
which tool is selected.  

Selection Tool 

Ruler Tool 

Rectangle Tool 

Ellipse Tool 

Single-Click Circle Tool 

Freeform Tool 

  

 
Please not that annotations are not currently saved into the slide. They can be used to carry 
out measurements. When the slide is closed all annotations are deleted.  

 

3.2.1. Drag Tool 
This tool will not create an annotation, but it will drag the slide so that the field-of-view changes. 
Annotations can be selected, by clicking on an annotation.  

3.2.2. Selection Tool 
This tool will create a temporary rubber band and select all annotations that intersect with the 
rubber band rectangle.  

3.2.3. Ruler Tool 
This tool will create a line. Click anywhere in the scene and then draw the line by keeping the mouse 
button pressed. The length of the line will be displayed and so it serves as a ruler. 

3.2.4. Rectangle Tool 
This tool will create a rectangle. Click anywhere in the scene and then draw the shape by keeping the 
mouse button pressed. When pressing the SHIFT button while drawing the shape, the rectangle will 
be forced to be a square. The rectangle’s width, height and area will be displayed. 

3.2.5. Ellipse Tool 
This tool will create an ellipse. Click anywhere in the scene and then draw the shape by keeping the 
mouse button pressed. When pressing the SHIFT button while drawing the shape, the ellipse will be 
forced to be a circle. The ellipse’s width, height (diameter in case of circle) and area will be displayed. 

3.2.6. Single-Click Circle Tool 
This tool will create a circle. In contrast to the Ellipse Tool, this tool will be create a circle for each 
mouse click. It is therefore suited to count events in the image. The diameter can be changed by 
scrolling the mouse wheel while keeping the ALT, CTRL or SHIFT-buttons pressed.  
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3.2.7. Freeform Tool 
This tool works like a pen and is used to create a polygons. Start drawing by clicking and keeping the 
mouse button pressed. The polygon will automatically be closed once the mouse button is released. 
The polygon’s area is displayed.  
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4. Further Functionality 

4.1. Save Current Live Image 

The user can save the current live image to a file  . 

4.2. Export into other Formats 
The user can export the stitched slide to other file formats via the “File” menu in the main menu bar 

of by clicking the    button.  

Currently supported “flat” formats: 

- PNG 
- JPEG 
- BMP 
- TIFF 

Currently supported “pyramid” formats: 

- Aperio SVS (TIFF container with JPEG tiles) 
- ZIF  (TIFF container with JPEG tiles) 
- TIFF (TIFF container with JPEG tiles) 
- DeepZoom (*.DZI) (incl. html file with interactive web-viewer) 

You want to export into a particular and it is not yet supported? Let us know. 

 
If you want to export only a region-of-interest, then create a rectangle annotation that marks 
the ROI and click on “File”|”Save As” while the rectangle annotation is selected.  
 
(Note that the Deep Zoom export currently does not support exporting a ROI and will always 
export the entire slide) 

 

4.3. Batch Exporting multiple Slides 
Instead of scanning and exporting slides one by one, you may want to choose to scan multiple slides 
first and then export them all at once afterwards, e.g. while you are on break or overnight. 

To do this, switch from the slide viewer back to the home screen and select those slides that you 
want to export in the workspace album or list view.  



IKOSA ISTIX 1.2 User Manual 
 

17 
 

 

If all slides shall be exported into the same format, you can multi-select items by pressing the SHIFT- 
or CTRL-key while selecting items. Then press the “Save As” button in the workspace view’s toolbar. 
Each “export job” will be added to the “WSI Export Queue”.  

Alternatively, you can select a single slide at a time and press the “Save As” button. Similarly, the new 
“export job” will be appended to the running queue. 

The queue processes two jobs at a time. The slightly larger progress bar at the top shows the overall 
progress. As soon as a job is finished, the icon turns green and the title will become clickable.  

4.4. Demo Sequences 
In order to demonstrate IKOSA ISTIX, demo sequences can be viewed under: View > Demo 
Sequences. 

4.5. Extended Depth of Field 
If the surface of an object is not flat, it cannot always be focused entirely. With a technique denoted 
Extended Depth of Field, multiple images taken at varying focus positions (aka z-positions) can be 
merged together into a single sharp image.   
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The above dialog shows the Extended Depth of Field dialog.  

• The left image shows the live frame 
• The center image shows a single image from a focus stack (images taken at same x- and y-

position, but different z-position).  
• The right image shows the fused Extended-Depth-of-Field image 

It is crucial to leave the x- and y-knobs untouched. Move only the focus-knob and at multiple 
positions click “Add to Stack” to assemble the focus stack.  

• When the dialog is started while not stitching, the resulting image can simply be saved in a 
“flat” image format such as JPG or PNG. For convenience, the individual focus stack images 
will be stored next to it.  

• When the dialog is started while stitching, the resulting image is inserted as a tile into the 
whole-slide panorama. Subsequently recorded overlapping tiles will always be placed under 
this tile. 

The dialog can be opened by pressing the  button in the main toolbar or from the “File” main 
menu. 
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5. Options Dialog 
The settings can be found under: File -> File > Options. All settings changes are automatically saved 
for the next session of IKOSA ISTIX. 

5.1. Select a Camera 
The cameras can be selected under: File -> Options > Camera. 

Some cameras (e.g. by IDS) will show up twice: via the native interface and via the generic 
DirectShow interface. It is highly recommended to select the native interface. 

 

Changing the camera will only take effect after the Option Dialog’s OK button has been pressed. 

5.2. Add, Remove and Edit Objectives 
The microscope objective settings can be found under: File -> Options > Microscope Objectives. 

As shown in the image below, objectives can be added, removed or edited. 

In order to add a new objective, press the plus button  . Then specify the magnification factor, the 
focal distance and further properties in the objective properties. The new objective can also be 
named. For deleting objectives, press the minus button  . For editing just select the objective of 
choice and change the respective values. 

 

 

5.3. Change Exposure Time 
The exposure time can be changed under: File -> Options > Microscope Objectives > Camera Main 
Settings. 

The exposure time (automatic calculation available) shall be adjusted such that the live view image is 
well illuminated. The exposure time may also affect the sharpness of the image perceived by IKOSA 
ISTIX. In case of underexposure or overexposure a warning is displayed during stitching. 
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5.4. Change Camera Color Settings 
The camera color settings can be changed under: File -> Options > Microscope Objectives > Camera 
Color Settings. 

Here the white balance (automatic calculation available), the saturation as well as the gamma value 
(automatic calculation available) can be changed.  

5.5. External Camera Control 
In case the camera is controlled with an external program, the camera settings can be disabled in 
IKOSA ISTIX by ticking “Do not touch camera settings”. 

 

Objective Editor with Camera Settings: 
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Objective Editor with Camera Settings for cameras by other manufacturers: 

 

It is camera-dependent which controls are available. In the above scenario, the red, green and blue 
colors cannot be adjusted individually, but only a temperature can be configured.  

5.6. Capture Workspace Options 
The capture workspace options can be found under: File -> Options > Capture Workspace. 

• Optimize Edges: if enabled (recommended), tile edges will be blended  
• Intermediate Format: Image compression format (Recommended is JPEG) 
• The intermediate file format for all stitching images and the intermediate data directory can 

be changed here. 
• Slide Naming Convention: enter here a format of how new slides shall be named. 
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5.7. Virtual Microscope 
In this options pane, the canvas background color can be changed: 

 

5.8. Locations 
The folder where IKOSA ISTIX stores permanent settings can be found under: File -> Options > 
Locations 

The application data folder contains the general settings (settings.ini), the microscope objective 
information, as well as log files. 
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6. Upload Images to IKOSA Platform 
The IKOSA® Platform provides comprehensive data management capabilities for your whole-slide 
images created with IKOSA ISTIX. It is an intuitive web platform designed for collaborative 
management, annotation and analysis of your images.  

6.1. Connection Settings 
The connection can be configured from the options dialog via File -> Options > IKOSA Platform.  

 

Have your IKOSA account credentials ready to upload and manage your images in IKOSA Portal. You 
need to enter: 

• username/email 
• password 

Test your connection settings afterwards. If the connection attempt succeeded, you will see a 
confirmation. If the connection failed, you will see an error message, e.g. that the username or 
password is invalid. 

  

IKOSA ISTIX provides default settings for the IKOSA Cloud instance, whose settings cannot be 
changed. For a detailed description and more advanced configuration such as connecting to your 
own installation of the IKOSA Platform, please see the section on Advanced Configuration Options. 

If you want to switch between different users, just update the credentials in this dialog. IKOSA ISTIX 
will then use the new user to connect. Once you close the options dialog the current user will appear 
in the status bar of the application. 

6.1.1. Creating an IKOSA Account 

If you do not yet have an account, you can create one by selecting , which will open a 
browser window and take you to the user registration page, where you can register with your email 
address.  

  



IKOSA ISTIX 1.2 User Manual 
 

24 
 

6.1.2. Advanced Configuration Options 
A description of the individual configuration options is provided in the following: 

 

 Option Description Example 
1 Preset Name The name under which the current settings 

are stored 
IKOSA Cloud 

2 Username/Email The username of the current user jane.doe@corporation.org 
3 Password The password of the current user SG4X?cq$tx 
4 WSI Format The format, whole slide images should be 

uploaded to IKOSA (defaults to SVS) 
 

5 OAuth API URL The host URL of the IKOSA OAuth API https://api.ikosa.ai 
6 Consumer ID The OAuth consumer ID for the IKOSA ISTIX 

application. For the default settings, it is 
preconfigured, for custom settings you may 
contact your system administrator. 

alpha-numeric string 

7 Consumer 
Secret 

The OAuth consumer secret for the IKOSA 
ISTIX application. For the default settings, it is 
preconfigured, for custom settings you may 
contact your system administrator. 

alpha-numeric string 

10 

9 

8 

7 

6 

5 

4 

3 

2 

1 

11 

https://api.ikosa.ai/
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8 Commons API 
URL 

The host URL of the IKOSA Commons API for 
user management 

https://api.ikosa.ai  

9 Portal API URL The host URL of the IKOSA Portal API https://portal.ikosa.ai  
10 Web App URL The host URL of the IKOSA web application https://app.ikosa.ai  
11 Test Connection Test the current connection settings.  
 

Managing Presets 

In order to configure your custom settings, duplicate any currently selected preset by pressing 

  and entering a new Preset Name. Similarly, remove a preset by pressing  . 

You may have multiple presets for different IKOSA server configurations, or users. Once you 
duplicate the presets, the default connection settings are applied to the new preset, but you will be 
able to alter them. 

  

https://api.ikosa.ai/
https://portal.ikosa.ai/
https://app.ikosa.ai/
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6.2. Uploading a Slide 
To upload your scanned slides to IKOSA Portal, go to the workspace view and select one or multiple 
slides you want to upload.  

Then press the  button in the workspace view’s toolbar in order to open the “Image 
Upload” dialog. 

 

Select a specific project via the dropdown list, into which you want to upload your slides and start 

the upload process with . If you want to share this project with your collaborators, click on 

 and add other users from your organization to the project. 

If you want to create a new project, please press the  button to open the corresponding 
dialog.  

. 

Enter the name (required) and a description (optional) for your new project and create the project by 

pressing . Afterwards start the upload as described above. 
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The selected slides are exported and uploaded to the chosen project in IKOSA Portal, the status of 
this process can be monitored in the “WSI Export Queue”. The queue processes two jobs at a time. 

 

6.2.1. Reveal uploaded Images in IKOSA Portal 
Once the upload has completed successfully, you can open the slide in the browser in two ways:  

1. In the “WSI Export Queue” the name of the image becomes a hyperlink, which by clicking 
directly takes you to the location in IKOSA Portal: 
 

 
 

2. In the gallery view, a small cloud icon  will appear in the top left corner of the image, 
which by clicking takes you to the location in IKOSA Portal. Hovering the icon will reveal the 
owner of the image (IKOSA username): 
 

  

 

At application startup, IKOSA ISTIX will check which images are connected to your currently 

configured IKOSA account and show the  symbol for images that are available for you in IKOSA 
Portal.  
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Using Multiple User Accounts 

If an image was previously uploaded, but cannot be found on the platform anymore, for instance 

because it was deleted, or you do not have access to the image, an error symbol  will indicate 
this. Click on the icon to show details of the error: 

 

The tooltip of the image reveals the IKOSA username of the person who uploaded the image: 

 

If you switch back to this person’s account, the image can be found again and the  symbol will 

switch back to the cloud symbol . 

 

6.2.2. Open IKOSA Portal from IKOSA ISTIX 

IKOSA Portal can be opened by pressing  in the workspace view’s toolbar. Your 
standard web browser is opened where you can login to IKOSA Portal with your IKOSA account 
credentials. IKOSA Portal allows you to further collaborate on your images with your colleagues such 
as adding annotations on the images, or running analysis algorithms. 
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7. Third Party Software  
This software utilizes various open source software libraries. Their licenses can be found in the 
“ThirdPartyLicenses” folder in the install directory.  

This software is based in part on the work of the Independent JPEG Group. 
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8. Contact Information 

 

KML VISION GmbH 
Nikolaiplatz 4/II 
8020 Graz 
Austria 
Web: www.kmlvision.com 

For more information on IKOSA ISTIX please visit the product website at 
https://www.kmlvision.com/istix. 

If you encounter unexpected behavior, please report it to our support team at  
istix-support@ikosa.ai. 

In case you have questions regarding the product, please get in touch with  
sales@kmlvision.com. 

With questions regarding custom developments, please get in touch with the contact listed at 
https://www.iis.fraunhofer.de/istix 

 

http://www.kmlvision.com/
https://www.kmlvision.com/istix
mailto:istix-support@ikosa.ai
mailto:sales@kmlvision.com
https://www.iis.fraunhofer.de/istix
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9. Legal Information 
 

iSTIX is a registered trademark of the Fraunhofer Society for the Promotion of Applied Research in 
the federal states: 

 
Germany                   302017107988 
European Union         1412595 
USA                               5,796,509 
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